flocon/hosts/anastacia/default.nix
Anthony Rodriguez b819cfc631
hosts: import hjem everywhere
This fixes evaluation issues when hjem is not a known option.
2025-02-06 15:20:32 +01:00

26 lines
637 B
Nix

{inputs, ...}: {
imports = [
./hardware-configuration.nix
./networking.nix # generated at runtime by nixos-infect
inputs.agenix.nixosModules.default
];
local = {
systemVars = {
hostName = "anastacia";
};
profiles.server.enable = true;
};
boot.tmp.cleanOnBoot = true;
networking.domain = "";
services.openssh.enable = true;
users.users.root.openssh.authorizedKeys.keys = [
"ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIEzs7SQH0Vjt9JHoXXmWy9fPU1I3rrRWV5magZFrI5al"
"ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIHKEPlN/GU9nJZPleA77HH5NA+6vyhhM84fTSjEwnEgq"
];
system.stateVersion = "23.11";
}