The options API has been updated, in order for a more flexible setup with `local.modules.desktop.enable` being replaced with an enum of desktops at `local.systemVars.desktop`, which allows for switching desktop environments by changing a single option. This is so that we can switch to cosmic and only enable the programs we need (i.e. disable greetd because we use cosmic-greeter and enable terminals since that is desktop related). This is simpler than having a different module per desktop.
23 lines
375 B
Nix
23 lines
375 B
Nix
{
|
|
lib,
|
|
pkgs,
|
|
config,
|
|
...
|
|
}: let
|
|
inherit (config.local.systemVars) username;
|
|
in {
|
|
imports = [
|
|
./tidal-hifi.nix
|
|
./zathura.nix
|
|
];
|
|
|
|
config = lib.mkIf (config.local.systemVars.desktop != "none") {
|
|
hjem.users.${username}.packages = [
|
|
pkgs.gnome-calculator
|
|
pkgs.gthumb
|
|
pkgs.spotify
|
|
pkgs.stremio
|
|
pkgs.celluloid
|
|
];
|
|
};
|
|
}
|