The options API has been updated, in order for a more flexible setup with `local.modules.desktop.enable` being replaced with an enum of desktops at `local.systemVars.desktop`, which allows for switching desktop environments by changing a single option. This is so that we can switch to cosmic and only enable the programs we need (i.e. disable greetd because we use cosmic-greeter and enable terminals since that is desktop related). This is simpler than having a different module per desktop.
40 lines
756 B
Nix
40 lines
756 B
Nix
{
|
|
lib,
|
|
pkgs,
|
|
config,
|
|
...
|
|
}: let
|
|
inherit (builtins) toJSON;
|
|
inherit (lib) mkIf;
|
|
inherit (config.local.systemVars) username;
|
|
in {
|
|
config = mkIf (config.local.systemVars.desktop != "none") {
|
|
hjem.users.${username} = {
|
|
packages = with pkgs; [
|
|
entr
|
|
fractal
|
|
fzf
|
|
geary
|
|
hyfetch
|
|
imhex
|
|
logisim-evolution
|
|
mission-center
|
|
obsidian
|
|
playerctl
|
|
proton-pass
|
|
qalculate-gtk
|
|
simple-scan
|
|
wl-clipboard
|
|
];
|
|
|
|
files = {
|
|
".config/hyfetch.json".text = toJSON {
|
|
preset = "nonbinary";
|
|
mode = "rgb";
|
|
backend = "fastfetch";
|
|
color_align.mode = "horizontal";
|
|
};
|
|
};
|
|
};
|
|
};
|
|
}
|