The options API has been updated, in order for a more flexible setup with `local.modules.desktop.enable` being replaced with an enum of desktops at `local.systemVars.desktop`, which allows for switching desktop environments by changing a single option. This is so that we can switch to cosmic and only enable the programs we need (i.e. disable greetd because we use cosmic-greeter and enable terminals since that is desktop related). This is simpler than having a different module per desktop.
20 lines
316 B
Nix
20 lines
316 B
Nix
{
|
|
lib,
|
|
pkgs,
|
|
config,
|
|
...
|
|
}: let
|
|
inherit (lib) mkIf;
|
|
inherit (config.local.systemVars) username;
|
|
in {
|
|
imports = [
|
|
./starship.nix
|
|
./nushell.nix
|
|
./zoxide.nix
|
|
./zsh.nix
|
|
];
|
|
|
|
config = mkIf (config.local.systemVars.desktop != "none") {
|
|
users.users.${username}.shell = pkgs.zsh;
|
|
};
|
|
}
|