flocon/modules/services/kmscon.nix
Anthony Rodriguez fc876b2ea5
treewide: update options API
The options API has been updated, in order for a more flexible setup
with `local.modules.desktop.enable` being replaced with an enum of
desktops at `local.systemVars.desktop`, which allows for switching
desktop environments by changing a single option. This is so that we can
switch to cosmic and only enable the programs we need (i.e. disable
greetd because we use cosmic-greeter and enable terminals since that is
desktop related). This is simpler than having a different module per
desktop.
2025-02-06 18:47:01 +01:00

22 lines
367 B
Nix

{
lib,
pkgs,
config,
...
}: {
config = lib.mkIf (config.local.systemVars.desktop != "none") {
services.kmscon = {
enable = true;
fonts = [
{
name = "0xProto Nerd Font";
package = pkgs.nerd-fonts._0xproto;
}
];
extraConfig = ''
font-size=13
font-dpi=144
'';
};
};
}