The options API has been updated, in order for a more flexible setup with `local.modules.desktop.enable` being replaced with an enum of desktops at `local.systemVars.desktop`, which allows for switching desktop environments by changing a single option. This is so that we can switch to cosmic and only enable the programs we need (i.e. disable greetd because we use cosmic-greeter and enable terminals since that is desktop related). This is simpler than having a different module per desktop.
21 lines
443 B
Nix
21 lines
443 B
Nix
{
|
|
lib,
|
|
config,
|
|
...
|
|
}: {
|
|
config = lib.mkIf (config.local.systemVars.desktop == "Hyprland") {
|
|
location.provider = "geoclue2";
|
|
|
|
services.geoclue2 = {
|
|
enable = true;
|
|
geoProviderUrl = "https://beacondb.net/v1/geolocate";
|
|
submissionUrl = "https://beacondb.net/v2/geosubmit";
|
|
submissionNick = "geoclue";
|
|
|
|
appConfig.gammastep = {
|
|
isAllowed = true;
|
|
isSystem = false;
|
|
};
|
|
};
|
|
};
|
|
}
|