The options API has been updated, in order for a more flexible setup with `local.modules.desktop.enable` being replaced with an enum of desktops at `local.systemVars.desktop`, which allows for switching desktop environments by changing a single option. This is so that we can switch to cosmic and only enable the programs we need (i.e. disable greetd because we use cosmic-greeter and enable terminals since that is desktop related). This is simpler than having a different module per desktop.
21 lines
346 B
Nix
21 lines
346 B
Nix
{
|
|
lib,
|
|
config,
|
|
...
|
|
}: let
|
|
inherit (config.local.systemVars) username;
|
|
in {
|
|
config = lib.mkIf (config.local.systemVars.desktop != "none") {
|
|
programs.ssh = {
|
|
startAgent = true;
|
|
};
|
|
|
|
hjem.users.${username} = {
|
|
files = {
|
|
".ssh/config".text = ''
|
|
AddKeysToAgent yes
|
|
'';
|
|
};
|
|
};
|
|
};
|
|
}
|