This fixes inherits and library functions usage, to inherit them explicitely at top level of the file.
16 lines
281 B
Nix
16 lines
281 B
Nix
{
|
|
lib,
|
|
pkgs,
|
|
config,
|
|
...
|
|
}: let
|
|
inherit (lib.modules) mkIf;
|
|
in {
|
|
config = mkIf config.local.profiles.gaming.enable {
|
|
hardware.keyboard.qmk.enable = true;
|
|
environment.systemPackages = with pkgs; [
|
|
via
|
|
];
|
|
services.udev.packages = [pkgs.via];
|
|
};
|
|
}
|