flocon/modules/programs/games.nix

37 lines
626 B
Nix

{
lib,
pkgs,
config,
...
}: let
inherit (lib) mkIf;
inherit (config.local.systemVars) username;
in {
config = mkIf config.local.profiles.gaming.enable {
hjem.users.${username} = {
packages = [
pkgs.mangohud
pkgs.bolt-launcher
pkgs.lutris
pkgs.qbittorrent
pkgs.protonplus
];
};
programs = {
steam = {
enable = true;
};
gamemode.enable = true;
gamescope.enable = true;
coolercontrol = {
enable = true;
nvidiaSupport = true;
};
};
services.hardware.openrgb.enable = true;
};
}